Jump to content
Monday 22 July 2024
tobiaslej

Felsökning Nmea 200 - BILD bifogad

Recommended Posts

Hej, jag har fått problem med att följande instrument tappar kontakten med plottern och ingen data visas:

 

1. Extern Gps - Är nästan konstant utan kontakt (kommer tillbaka ngn enstaka gång)

2. Motordata - Har kontakt ibland, men inte alltid.

3. Tanknivå - Har kontakt ibland, men inte alltid

4. Vattentemp - funkar alltid (verkar inte vara kopplad via N2K, kanske direkt t plottern då?)

 

Bilden visar kopplingen. Fr vä till höger är det inkopplat: Motordata, GPS, Plotter, Tanknivå, N2K power.

 

Finns det ngn chans att jag som lekman kan felsöka och fixa problemet? Hur göra isf?

 

 

PXL_20240530_162623425.jpg

Share this post


Link to post
Share on other sites

Vad händer till höger i bild? Fortsätter det en sladd där till något annat eller slutar den med en terminering där?

Share this post


Link to post
Share on other sites
Just nu skrev rejas:

Vad händer till höger i bild? Fortsätter det en sladd där till något annat eller slutar den med en terminering där?

Slutar med en terminering där.

Share this post


Link to post
Share on other sites

Ok. Normalt brukar man vilja ha strömförsörjningen i mitten, men på ett så litet nät med så kort backbone har det knappast någon betydelse.

 

Har det någonsin fungerat? Om det har fungerat och nu slutat så är det kanske någon kontakt som slutat fungera. Det brukar sitta små o-ringar på dem men om de gått sönder eller saknas kan de vara ärgiga. Det kan också vara någon av givarna som beter sig illa.

 

Skruva isär allt och kolla (det är lätt att sätta ihop igen) kopplingarna. Testa sedan att sätta i givarna en och en och testa dem i olika t-kopplingar så kanske du kan dra någon slutsats.

Share this post


Link to post
Share on other sites
Posted (edited)

Det har fungerat. Båten och systemet är 3 år gammalt. Började krångla för ett par veckor sedan och allt kom samtidigt, så tycker det är lite konstigt att de olika instrumenten började strula samtidigt, men kan fungera var för sig emellanåt.

Det borde man kunna dra ngn slusats av, men vad? :)

 

Ska börja med ditt förslag och skruva isär det och koppla in en och en på olika kontakter.

Edited by tobiaslej

Share this post


Link to post
Share on other sites

Hur långa är tappningskablarna ?  Är de långa och många relativt ditt backbone blir impedansen i bussen så fel att data kan bli korrupt. Fast det har ju fungerat skriver du...

 

Räcker dock med att ett enda instrument får något fel på sitt interface för att lasta ner och sabotera signalerna på bussen för alla.

En annan sak som jag råkat ut för är att någon enhet har gjort fabriksåterställning och fått ett default-ID som kolliderar med en annan enhets ID. Men då borde det bara vara två som har problem.

 

Så gör som @rejas skriver - koppla isär och kör enheterna en och en.

Share this post


Link to post
Share on other sites

Elektronikrengöring kan med lite tur göra underverk.

https://assets.cdn.jula.com/preset:jpgoptimized/w:828/Dmm3BWSV3/assetstream.aspx?assetId=5933&mediaformatid=50137&destinationid=10016&lastmodified=19790101000000

Om allt har fungerat och nu helt plötsligt slutat fungera utan att du har gjort några förändringar så är det med lite tur något enkelt fel.

 

Jag håller med alla andra. Börja med att lossa varje kontakt, spraya lite rengöring på kontakten och koppla ihop den igen.

 

Hjälper inte det så får du vara lite mer systematisk. Koppla bort del efter del och kolla ifall du kan lokalisera vilken del som felet sitter i.

assetstream.webp

Share this post


Link to post
Share on other sites

Jag har nu monterat ner det, använt elektronikrengöring, flyttat så att strömmen läggs på mellersta anslutningen.

 

Kan glädjande rapportera att jag inte fått tillbaka felet så det fungerade! Tack för hjälpen :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...